Setting up the EAchine Wizard x220 for SBUS with an Evolution and TGY-iA6C

Note: You should be able to click on any picture to open a full-sized version if it.

Wizard x220, as shipped – three pin connector, connected to IO1 port using PPM pin.

The EAchine Wizard x220 ARF version currently ships with a connector hanging off IO1 on the F3 control board.  This might be fine for some receivers, but generally won’t work as-is for the receiver that ships with the Turnigy Evolution… a TGY-iA6C.  The yellow wire on the supplied connector is attached to IO1’s “PPM” pin.  Unfortunately, if you plug that into a iA6C without “fixing” it, it’ll plug in to the SBUS pin on the receiver.  SBUS and PPM are two separate things, so that’s not going to work.  SBUS is generally considered to be the better protocol, so most people with an Evolution are going to want to switch to that.  To start, take the top plate off the Wizard and let’s go digging.

IO1 port on F3 board

That’s the port you’re looking for above.  If you zoom in on mine (click the picture), you’ll see there are 8 wires coming off that plug.  On mine, it originally looked like three of those wires went to the receiver plug and the other 5 went under the flight control board… So, I didn’t want to unplug it and mess with those 5 wires.  Well… EAchine just cut those five wires and what I was looking at was a little over a 1/4″ of wires that they bent to face downwards.  Unplug that critter and plug it into the socket on the other side of the board…

IO2 port connected to TGY-iA6C using SBUS

Here’s what it should look like for SBUS, with one exception…  I took off the three pin connector it came with and put on the four pin connector that came with the iA6C.  You don’t need to do this…  I just wasn’t thinking very well.  If you zoom in, you’ll see that I added little markers to all the pins…  1 is ground, 2 is VCC (power), 3 is SBUS.  I also put markers on the pads you can solder to directly on the controller if you prefer.  Note that you have to use UART3 for SBUS.  Also, you can’t use the UART3 pads for one thing and the IO2 pins 1-3 for something else… they’re the same things.

Just to make sure we’re all on the same page here…  when you plug the three pin connector into your receiver, the black wire should line up with the pin labelled “GND”, red should line up with “VCC” and white should line up with “SBUS”.  Nothing should line up with PPM and it’ll probably be hanging off the side of your connector instead of being covered by a slot with no wire like mine.

So, that’s the physical connections handled…  Now, we have to set the transmitter.  If you’re using the Rx that came with Evolution, it’s already bound to the transmitter.  If you are using a different one, you’ll have to bind it (I might write up how to do that later).  Then, turn on the transmitter and click the wrench icon to change the settings.

Then, slide the screen up until you see Output Mode.  Click on that.

Now, click on the S. BUS “button”.  Don’t worry about the other settings.

Now, we just need to set up the flight controller to tell it to use S. Bus.  I use Betaflight on the Wizard.  Cleanflight is similiar enough that you should be able to figure it out if you prefer to use that.  Plug your quad into your computer and open Betaflight.  If it doesn’t connect automatically, click the Connect icon in the top right corner.  Once connected, click Ports.

Ports for SBUS config on Betaflight for x220 with TGY-iA6C

Turn on UART3 SerialRX.  Don’t mess with anything else!  Do NOT mess with UART1… you’ll get to solder stuff if you do.

Once you’ve turn on UART3’s SerialRX setting, click Save and Reboot.  Once your controller reboots, reconnect it and click Configuration.

Configuration for SBUS config on Betaflight for x220 with TGY-iA6C

Set the Receiver Mode to “Serial-based reciever (SPEKSAT…”.  When you do, it’ll show you another box for Serial Receiver Provider.  Set that to “SBUS“.  Click Save and Reboot.  Reconnect when rebooted and go to Receiver.

Note to self: Add screenshot here… I skipped that one.

We’ve now told everything how to communicate.  We need to give the Wizard some power to verify that it works.  Before we plug it in, I have to warn you…

Make SURE you don’t have any props installed at this point!  There are lots of ways to accidentally spin up your motors in Betaflight/Cleanflight… don’t risk it.  Also make sure nothing is touching the motors (like your USB cable).  Finally, make sure that all your electrical bits aren’t touching any of the carbon fiber.  Carbon fiber is a conductor…  imagine your whole frame is made out of copper.

Ok, turn on your transmitter and plug in a battery to power up your Wizard… You should now be able to move the sticks and see the guages in Betaflight moving around.  If you don’t, review the Port and Configuration screens again.  I found my Configuration setting didn’t stick the first time and I had to do it again.

You should now have a working quad that responds to your tranmitter. Congrats!

Now you get to go deal with your Modes… that’s a discussion for another time.

Modes for SBUS config on Betaflight for x220 with TGY-iA6C

Leave a Reply

Your email address will not be published. Required fields are marked *